I need EFSEO for Joomla 1.5

6 years 1 month ago #9018 by floatingworld
I need EFSEO for Joomla 1.5 was created by floatingworld
HI I need EFSEO for a Joomla 1.5 site a client has. Can anyone give me a copy of the EFSEO extension for Joomla 1.5? It is urgent.

Please Log in to join the conversation.

6 years 1 month ago #9019 by Vitja
Replied by Vitja on topic I need EFSEO for Joomla 1.5
Please login to view the response. Attention: You need a valid subscription to activate an account.

Kubik-Rubik Joomla! Extensions

Please support my work with a review in the Joomla! Extensions Directory: extensions.joomla.org/profile/profile/details/61997

Please Log in to join the conversation.

Time to create page: 0.135 seconds